Terminals in NX-session displayed as if empty and in grey

Forum / NoMachine for Mac / Terminals in NX-session displayed as if empty and in grey

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
  • #11343


    I’m trying to connect to my OpenSuse 12.3 (KDE) clients using NX 4.2 and upgraded to 5.6 but same problem with the displayed contents

    Connection works fine but when opening a terminal or application on the remote client, like Yast or a terminal, it’s content is hidden, accessable but not display or drawn. I can only see a grey or after upgrade a black background color insted of text. Entre Yast is hidden in grey.

    I’m connecting from a OS X 10.9.

    How can I fix this?




    It looks this problem occurs when you run Yast and Konsole with root privileges. This causes a failure when trying to use shared memory. This isn’t usually a problem, but error is not correctly handled by the toolkit library.

    Workaround: set QT_X11_NO_MITSHM=1 in the environment when you want to run Yast or any Qt application requiring root privileges:

    env QT_X11_NO_MITSHM=1 yast2

    env QT_X11_NO_MITSHM=1 konsole



    Thks for answer, tried the env thing but doesn’t work.
    Tried both to set QT_… on machine directly aswell as on nx-connection. Also tried to use export instead. No success.

    Have verified the variable settings in env with echo $QT_ …

    Funny thing is that it looks just as the contents is lacking in visual transport to me, when I click randomly inside Yast2 grey area it finds and starts the actual program in the grey “fog”.



    Hi again,

    First what is the difference between XTerm and the Terminal? I’m running a GUI-application in xterm that I can’t see upfront, however if I start a terminal and from there start the application it works, apart from sizing…

    Secondly: I’m testing further on “set QT_X11_NO_MITSHM=1” and find that:

    If I use “env QT_X11_NO_MITSHM=1” or “set QT_X11_NO_MITSHM=1” doesn’t stick, however “export QT_X11_NO_MITSHM=1” does stick a while in “this” terminal

    Though using first export… and then “sudo /sbin/yast2” lets me enter the rootpwd and then enter the old blueish gui instead of the KDE gui.

    If I try to run without sudo like this: “/sbin/yast2” the userlevel version where only no root privileges are displayed of KDE Yast2.

    Thirdly: in .Xresource I have -*-fixed-medium-r-*-*-24-*-*-*-*-*-iso8859-1

    When changing 24 to lower value like 20, it does change the displayed size, however not its content.

    If I change back to original: “-adobe-courier-medium-r-normal–24-140-100-100-m-110-iso8859-1”

    I can see the content but size is small and barely readable.



    First: I think doesn’t matter the difference between Terminal (Konsole?) and xterm. The environment variables of shell attached to the terminal is what really matters. I think the environments differ between shells. You can dump environment variables using command “env” without arguments.


    Second: The command to set a variable in the environment depends on the shell in use. I guess you are using bash, because you wrote that command export QT_X11_NO_MITSHM=1 worked (all subsequent commands will inherit that variable). Provided Yast requires root privileges, do as follows:

    • run Konsole terminal emulator
    • gain root privileges running su -
    • set variable: export QT_X11_NO_MITSHM=1
    • run command yast2

    If the blue text mode interface is shown, check the value of DISPLAY variable


    Third: I have no .Xresource at all (and no font issue). Same openSuSE version. Which is the program having the font issue? Konsole? Xterm?



    Hi and thks for reply

    did as you described, however the export doesn’t work. if I use env | grep QT_X11_NO_MITSHM, No matter if I user or su, result is still empty.

    If I run yast2 or /sbin/yast2 to be precise, without su I end up in non priv mode and GUI, and if I use su I end up in blue yast2


    OK, my file is in /home/username/.Xresources as hidden file.

    The xterm is the one with an issue.



    Oh, when I dump the ‘env’ variables, after running the command and closing terminal (konsole) and the reopen the terminal. I seem to have lost the variable. “env | grep QT_X11_NO_MITSHM” returns nothing


    I seems that sudo resets the DISPLAY variable and gives you the blu text interface. So use su, not sudo. All the previous instructions can be combined in a single command, just open Konsole or XTerm and run:

    env QT_X11_NO_MITSHM=1 su -c yast2


    About font issue, please upload your .Xresource file.


    attaching my .Xresources file without the ‘.’ in the name


    Hi, can you send direct to forum[at]nomachine[dot]com?

Viewing 10 posts - 1 through 10 (of 10 total)

Closed because the user did not provide further feedback. Please notify us if you confirm that it is resolved or open a new topic if you have the same problem.