Unable to get audio working in Rocky Linux 9

Forum / NoMachine for Linux / Unable to get audio working in Rocky Linux 9

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #46421
    bryan3301
    Participant

    I also trying to make sound work on Rocky Linux 9.3. I ran across this article:

    Centos NoMachine server no sound

    sudo /usr/NX/bin/nxnode --audiosetup /etc/pulse
    sudo /etc/NX/nxserver --restart

    After running the commands above, I do see the NoMachine Outputs and Inputs. So far; however, I still do not have audio coming though.

    #46422
    bryan3301
    Participant

    Here is the full process I used to get NoMachine working on Rocky Linux 9.3.

    Download NoMachine

    Install NoMachine via local RPM

    sudo rpm -i nomachine_8.10.1_1_x86_64.rpm

    Create firewall service entry

    sudo cat << EOF > /etc/firewalld/services/nomachine.xml

    nomachine

    NoMachine

    tcp” port=”4000″/>

    EOF

    Configure firewalld

    sudo firewall-cmd –permanent –zone=trusted –add-service=nomachine

    sudo firewall-cmd –permanent –zone=home –add-service=nomachine

    sudo firewall-cmd –permanent –zone=internal –add-service=nomachine

    sudo firewall-cmd –permanent –zone=work –add-service=nomachine

    sudo firewall-cmd –reload

    Change to console boot (disable GUI boot). This is so the NoMachine X server is used, which will properly resize the remote display as the client window is resized.

    sudo systemctl set-default multi-user.target

    Configure pulseaudio to work with PipeWire (https://kb.nomachine.com/AR07T01168)

    sudo dnf install pulseaudio –allowerasing

    sudo dnf install pulseaudio-utils

    sudo /usr/NX/scripts/setup/nxnode –audiosetup

    Configure audio (https://forum.nomachine.com/topic/centos-nomachine-server-no-sound)

    sudo /usr/NX/bin/nxnode –audiosetup /etc/pulse

    sudo /etc/NX/nxserver –restart

    Reboot

    #46449
    Britgirl
    Participant

    This topic was spun off from another post about audio (on Alma Linux) by the admins. Are you still having problems with getting audio to work?

    For some tips on how to set up NoMachine with Pipewire, take a look at the following articles:

    How to enable audio on systems relying on PipeWire for sound
    https://kb.nomachine.com/AR07T01168

    How to support audio in NoMachine virtual desktops on Linux host using PipeWire
    https://kb.nomachine.com/AR12U01215

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.