Forum Replies Created

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
  • s.minacapelli

    *** I FOUND A SOLUTION ***

    The problem is now clear and REPEATABLE. There is a bug (I think) but there is also a temporary simple solution.

    Very often I use “New connection” from NoMachine menu, because I’m in a testing environment.
    Starting a new connection, a series of intermediate windows are displayed before the final GNOME or KDE desktop.
    At the bottom of each intermediate window “Don’t show this message again for this connection” is displayed on the left and the OK button on the right.
    If I click on the OK button of each intermediate window in rapid sequence, I get a final GNOME or KDE desktop with WRONG display resolution set to 800×600.
    If I wait some seconds, so that when I click on the OK button of the last intermediate window (see ATTACHMENTS) the background of that window is highlighted, then I get a final GNOME or KDE desktop with display resolution correctly set to 1366×768.
    Moreover, the correct display resolution is also set when no intermediate windows are displayed at all, i.e. after “Don’t show this message again for this connection” is flagged for all intermediate windows.

    ATTACHMENTS: last intermediate window with and without highlighted background


    I’m using the embedded X server of NoMachine 6.4.6 free edition for Linux, on CentOS 7 environment.

    On CentOS 7, I run the command

    systemctl get-default

    getting the output


    Of course, to use the embedded X server of NoMachine, I didn’t run systemctl set-default graphical.target. Is that enough or something else is needed to turn off the display service?



    … and, sorry, I say “physical resolution 800×600” because if I run
    systemctl set-default graphical.target

    so using the standard X server, I get a connection to a physical display 800×600.


    I’m using  free version NoMachine for Linux 6.4.6 on both client and server.

    The problem about GNOME virtual desktop was fixed with release  6.1.6 and my problem is there also with KDE desktop.

    The problem is that, when the connection occurs, sometimes the display is set to the correct resolution of 1367×768 and sometimes it is set to the physical resolution 800×600. Never the desktop reverts to another size during normal operation.

Viewing 4 posts - 1 through 4 (of 4 total)