Forum Replies Created

Viewing 15 posts - 1 through 15 (of 65 total)
  • Author
  • in reply to: Discovery on LAN not working correctly #48371


    1 Please ensure that all machines are on the same network and that mDNS broadcasting is not blocked by a router or by having the machines on different subnets.

    2 Verify that on the machines where other servers are not visible in NXPlayer, the option Player Settings -> Security -> 'Don't show other computers on this LAN' is not checked.

    If steps 1 and 2 do not help, please proceed:

    3 On a machine where other servers are visible and on a machine where the issue occurs (servers are not visible), please run the following commands in the CMD on both machines:

    3.1 Check if the %HOME% environment variable is set by running:

    echo %HOME%

    If it’s not set, you can set it with the following command:

    set HOME=C:\Users\YourUsername

    Note: Replace YourUsername with your actual username.

    3.2 Execute the nxlocate -s command:

    "C:\Program Files\NoMachine\bin\nxlocate.exe" -s

    Note: The path may be different depending on where NoMachine was installed.

    You should see a similar output:

    C:\>"c:\Program Files\NoMachine\bin\nxlocate.exe" -s
    19308 8516 2024-06-03 17:46:32 022.453 Features/Features: WARNING! Can't open version file 'C:\Program Files (x86)\NoMachine\etc\version'.
    19308 8516 2024-06-03 17:46:32 022.453 Features/Features: WARNING! Error is 2, 'No such file or directory'.
    19308 8516 2024-06-03 17:46:32 022.453 LocateMain: Creating locate client.
    19308 8516 2024-06-03 17:46:32 022.453 LocateMain: Running locate application.

    After this, type the following command and press Enter:


    Wait at least 1 minute and then collect the output. During this time, all servers should show up as a response in CMD.
    After at least 1 minute, please break by pressing Ctrl + C and send us the output.

    Send it directly to forum[at]nomachine[dot]com.

    Repeat the above steps on both machines where it works and where it doesn’t.


    It seems like your firewall might be blocking UPnP traffic from your router, which could prevent the router’s response to the UPnP request from reaching your machine.

    If you’re using the default firewall on Linux Mint, which is typically ‘ufw’, you can allow incoming UPnP traffic from your router by executing the following command:

    ufw allow from port 1900 to any proto udp

    After allowing this traffic, you can initiate UPnP mapping by running:

    /etc/NX/nxserver --upnpmap

    Once done, UPnP should be operational on your machine. Remember to repeat this process on every machine where UPnP functionality is required.

    Note: To find your router’s IP address, you can use the following command:

    ip route | grep default

    If you’re using any additional outer firewalls, ensure to add a similar firewall rule to allow UPnP traffic as mentioned above.


    Hello ddrucker,

    if the NoMachine network daemon (nxd) is configured on the server to listen on a different port, it’s necessary to modify the web connection settings as you probably already did.

    But also it’s necessary to modify client.crt file.

    Assuming hots wasnt changed, and in Server Section is used localhost or,
    but NXD port changed to 4400

    Update the client.crt file, on Linux /var/NX/nxhtd/.nx/config/client.crt, to have:

    Host:localhost 4400
    -----END CERTIFICATE-----
    Host: 4400
    -----END CERTIFICATE-----

    Please check article bellow for more details,

    in reply to: NX webplayer server configuration #35795

    Hello k.gorbachev,

    ensure that ownership (nxhtd:nxhtd) and permissions (700, on Linux and Mac) are preserved for the new connection file.

    Please check by executing:

    ls -lah /usr/NX/share/config

    To set proper ownership and permissions on Linux or Mac:

    chown nxhtd:nxhtd cfm.nxs
    chmod 0700 cfm.nxs

    For instructions please see:

    in reply to: 110 Connection time out on Android tablet #34338

    Hello Girgburg,

    you wrote:

    but when I try to replace “none” with “for users connecting with the NX protocol”

    to be sure, can you please make sure that key EnableUPnP in server.cfg is set only to NX,
    so the whole line would looks like:

    EnableUPnP NX

    if not, please change to be like above.

    UPnP/NAT-PMP port mapping is enabled by default in NoMachine (free) version

    Please also make sure that on your router device, UPnP is enabled.
    If not, you will have to enable UPnP.

    Then on Windows: start cmd.exe as root (Administrator) and execute those commands

    # To start port mapping:
    "C:\Program Files (x86)\NoMachine\bin\nxserver.exe" --upnpmap

    #To display status and ports:
    "C:\Program Files (x86)\NoMachine\bin\nxserver.exe" --upnpstatus

    in reply to: No port number shown for my machine #33639

    Hello jxu,

    we would need to collect debug logs.
    Restart router, wait till it finish and repeat all the steps on both machines, Linux and Mac:

    1 Enable debug and restart nxserver:

    sudo /etc/NX/nxserver –debug –enable all
    sudo /etc/NX/nxserver –restart

    2 Reproduce the problem

    sudo /etc/NX/nxserver –upnpmap
    sudo /etc/NX/nxserver –upnpstatus

    3 Collect logs and disable debug:

    sudo /etc/NX/nxserver –debug –collect
    sudo /etc/NX/nxserver –debug –disable all
    sudo /etc/NX/nxserver –restart

    4 Please send to us also server.cfg files from both machines, Linux and Mac.

    This article explains how to collect the logs:
    Please attach logs to your reply here or you can send them to forum[at]nomachine[dot]com making sure to use the topic’s title in the subject.

    in reply to: No port number shown for my machine #33581

    Hello jxu,

    – as first stop/disable zerotier service.

    – then to disconnect its interface please try this command:

    nmcli device disconnect ztbpamnldl

    – check if this interface id disconnected, by:

    nmcli device status

    when all goes ok, and there will be only one interface enabled/connected,
    restart nxserver, reproduce and please let us know if this helps:

    sudo /etc/NX/nxserver –restart
    sudo /etc/NX/nxserver –upnpmap
    sudo /etc/NX/nxserver –upnpstatus

    in reply to: No port number shown for my machine #33568

    Hello jxu,

    on Linux machine I see those 2 interfaces

    wlp2s0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST> mtu 1500
    inet netmask broadcast

    ztbpamnldl: flags=4163<UP,BROADCAST,RUNNING,MULTICAST> mtu 2800
    inet netmask broadcast

    could you please, for test purpose, disable/remove ‘ztbpamnldl’ interface,
    so there will be only one ‘wlp2s0’ like on Mac os.

    May I ask what is this ‘ztbpamnldl’ interface?

    Then restart nxserver, reproduce and please let us know if this helps:

    sudo /etc/NX/nxserver –restart
    sudo /etc/NX/nxserver –upnpmap
    sudo /etc/NX/nxserver –upnpstatus

    in reply to: No port number shown for my machine #33560

    Hello jxu,

    we would need some more information:

    Can you describe the network infrastructure

    – router model / version
    – is there more than one router / network interfaces on which Linux machine is connected?
    – are both machines connected to the same router, both over wifi/lan or mixed?

    To list all interfaces on Mac and Linux, you can execute in terminal following command and show here the ouput:

    ifconfig -a

    in reply to: NoMachine server with ipv6 address #32523

    Hello Fedour,

    we do not support UPnP for IPv6

    You will have to configure the router manually through its administrative interface and set there Port Opening/Port Forwarding.

    Some general guidelines you can find in this article:

    in reply to: Cloud Server Web Player has an error #31832

    Hello cadavis22,

    we could not reproduce this issue.

    Could you try gather logs with steps from here?

    It must be done in cmd as administrator user.

    After enabled logs, please reproduce issue, and then gather the logs.
    Please send to us also htd.cfg and server.cfg configuration files.

    If it is possible, could you try nxplayer to connect to the same host,
    to see if this works?

    Please send the logs to forum[at]nomachine[dot]com using the title of this forum’s thread as the mail’s subject.

    in reply to: Can’t change GW port on the server settings #31628

    Hello ziomario,

    There is known issue, when you change GW port from GUI, and after that changed service status, like restart/stop/start, it won’t save that port.

    However, when you change GW port from GUI and then simply “go back”, without changing service’s status, it should works.

    So if you could please try this one – open GUI, change GW port, and just after it simply “go back”. Then return to that section and check if changes was saved?

    For other ways how to change GW port please refer to

    in reply to: Can’t change GW port on the server settings #31557

    Hello ziomario,

    may I ask what version are you using, and if it is not not the latest one could you upgrade to the last one?
    We recently fixed a problem with UPnP port

    Otherwise please tell us on what Os does it happen, how exactly do you change “Gateway” port,
    and how do you check it use old one [ by calling ‘nxserver –upnpstatus’ command maybe? ].

    in reply to: WARNING! /usr/NX/etc/htd.cfg #31113

    Hello buzz,

    this is a known issue and a fix should be in the next release.

    in reply to: Disable mDNS traffic #30398

    Hello bsper2,

    unfortunately there is no other way.

    It’s a client side setting, the only option is to change the CFG of all clients, wherever they are.

    Maybe the best thing for you could be distributing a CFG for all users, so they could copy it in $HOME/.nx/config
    on their side.
    Please also remember to change that setting on server side for each and every user in their “$HOME/.nx/config” directory.

Viewing 15 posts - 1 through 15 (of 65 total)