kubaszym1

Forum Replies Created

Viewing 15 posts - 1 through 15 (of 59 total)
  • Author
    Posts
  • kubaszym1
    Participant

    Hi,

    I checked the file “no-sound-forwarding.txt” that you sent and your configuration seems to be fine, all the variables and devices are set properly. Something blocks the audio transfer completely, despite proper configuration. I will try to reproduce your issue and investigate further. In the meantime, can you send me the logs from both sides? You can check it how to do it here: https://kb.nomachine.com/DT07S00243.

    Regards,

    Kuba

    kubaszym1
    Participant

    Hi,

    Please try again using the commands exactly as they are above. I realised that they were formatted incorrectly, now corrected.

    kubaszym1
    Participant

    Hi,

    You can check if you have “Exclusive mode” set for your headset. Exclusive mode is a feature that allows an application to get exclusive use of an audio device. It’s possible that turning it on (or off) for the bluetooth headset will make a difference. Go to Sound Control Panel, open “Device properties” of your headset, then go to “Advanced”. Then you can check/uncheck “Allow applications to take exclusive control of this device” in order to turn on/off the exclusive mode.

    Please let me know if you notice any difference during a NoMachine session.

    Regards,

    Kuba

    kubaszym1
    Participant

    Hi,

    Do you mean that the headset is connected to the windows machine (server) – you can hear audio from Windows with this headset outside the session? I know you wrote it but I want to be sure. Do you connect the headset before or during the NoMachine session?

    If the bluetooth device is connected to the client machine, you should see it on the device list in NoMachine settings (click on right up corner of the NoMachine window, then go to Audio -> Change settings). You can set it as an output device on the client side.

    But if your headset is connected to the server, we will try to reproduce the issue and fix it.

    Regards,

    Kuba

    in reply to: USB Microphone input #46297
    kubaszym1
    Participant

    Hi,

    It’s also possible that something went wrong in configuration during the installation – you once wrote that you have AudioInterface set to “pipewire” but do you use PipeWire? In order to check, run:

    pactl info

    1) if Server Name is ‘pulseaudio’ then you use PulseAudio and AudioInterface should be set to “pulseaudio”. You can change this in /usr/NX/etc/node.cfg and then restart NoMachine server.

    2) if Server Name is ‘PulseAudio (on PipeWire 0.3.x)’ then you use PipeWire and in this case I will have to investigate your issue in order to find out where the problem is.

    Best regards,

    Kuba

    kubaszym1
    Participant

    Hi,

    Your issue can be caused by several things. In order to determine if you’re using PulseAudio or PipeWire you can run this command:

    pactl info

    if ‘Server Name’ is pulseaudio – you use PulseAudio, but if it’s something like ‘PulseAudio (on PipeWire 0.3.x)’ – you use PipeWire. Then you can restart your audio service and hopefully the sound will return:

    1) For PipeWire: systemctl --user --now restart pipewire.{socket,service}

    2) For PulseAudio: systemctl --user --now restart pulseaudio

    In some cases you may need to restart your computer.

    Regards,

    Kuba

    in reply to: Remote VPS Ubuntu 22.04 with xcfe4 NoMachine no sound #46144
    kubaszym1
    Participant

    Hi,

    PULSE_SERVER should be set automatically to /run/user/<uid>/pulse/native/. If it’s not set properly, the sound won’t work even outside NoMachine session. You can check it’s value by running ‘pactl info’ (first line of the output). This command may crash because you have some issues, so you can also just set PULSE_SERVER manually – ‘export PULSE_SERVER=/run/user/<uid>/pulse/native/’. Then please restart pulseaudio server.

    If you experience these sound issues only during NoMachine session you can gather logs from the session and send it to forum[at]nomachine.com. Collecting logs: https://kb.nomachine.com/DT07S00243

    Best regards,

    Kuba

    in reply to: USB Microphone input #46100
    kubaszym1
    Participant

    Hi,

    You can already try the next version – NoMachine 8.10.1. It’s possible that it will solve your issues. If not, please check your configuration – I noticed that your logs contain some configuration errors on the server side. Please check if the property AudioInterface from /usr/NX/etc/node.cfg is set to “pipewire”. You can also check the environment of the nxnode process. Find nxnode PID using i.e. ‘ps -aux | grep nxnode’, run ‘cat /proc/<pid>/environ’ and look for XDG_RUNTIME_DIR=/run/user/<user_id>. If XDG_RUNTIME_DIR is not set properly you can experience issues with transferring audio.

    Best regards,

    Kuba

    in reply to: Fedora 39 pipewire – no audio #46026
    kubaszym1
    Participant

    Hi,

    Are you able to hear sound from your machine outside NoMachine session? I’m not sure if it’s possible if you only have auto_null. Your built-in device should be set as the default sink, or some other physical device, i.e. headphones or external speakers. When NoMachine makes a connection between two machines, it connects to the default sink and captures its output data. This means that even if NoMachine is able to connect to auto_null (Dummy Output), if auto_null doesn’t receive any data, you don’t hear anything on the client side.

    If your Fedora is a virtual machine, you should probably connect it to the speaker of the physical machine and enable audio in virtual box settings (or any software you’re using for virtualization) and then test the connection via NoMachine.

    Regards,

    Kuba

    in reply to: Linux client printer forwarding to Windows server #45951
    kubaszym1
    Participant

    Hi,

    You should be able to forward a printer during the session via NoMachine Player settings. Go to Devices -> Connect a printer and there you should see all the available printers. Click on your local printer and connect it to the server. If the printers don’t show up there, please gather logs from both sides as described here: https://kb.nomachine.com/DT07S00243

    You can also show us how you tried to forward the printer by attaching a screenshot of each step.

    Regards,

    Kuba

    in reply to: USB Microphone input #45927
    kubaszym1
    Participant

    Hi,

    I checked your logs and unfortunately I couldn’t find the explanation for your issue. Can you ensure that you set the highest log level (9 – Debug) and gather logs again? Without debug logs I cannot tell why NoMachine Microphone is not created.

    Regards,

    Kuba

    kubaszym1
    Participant

    Hi,

    I checked your logs and compared it to our code that handles creating of pulseaudio server for virtual sessions. Indeed, pulseaudio server needs client.conf file and such file doesn’t exist in /usr/NX/share/audio. The command that you used – nxnode --audiosetup – should copy this file from /etc/pulse/ to /usr/NX/share/audio. I’ll try to find out why it didn’t work. Meanwhile, you can copy client.conf file from /etc/pulse to /usr/NX/share/audio, restart the server and try to connect again. I hope it will fix the issue.

    Best regards,

    Kuba

    in reply to: NoMachine sessions crashes on adding printer? #45924
    kubaszym1
    Participant

    Hi,

    I would like to have some information in order to investigate your issue.

    1) Do you use Windows 11 as a NoMachine client or as a NoMachine server?

    2) Please reproduce the issue and collect the logs as described here: https://kb.nomachine.com/DT07S00243

    Then you can send the logs to forum[at]nomachine.com.

    Best regards,

    Kuba

    in reply to: USB Microphone input #45818
    kubaszym1
    Participant

    Hi,

    It seems that there is an error during the connection that breaks the process of creating virtual devices. There are several explanations for such issue, so I need some more information. Please gather logs from the server side as described here: https://kb.nomachine.com/DT07S00243 and send them to forum[at]nomachine.com.

    Regards,

    Kuba

    in reply to: USB Microphone input #45774
    kubaszym1
    Participant

    Hi Silvo,

    It seems that everything works fine. Let me explain how our audio support works on Linux:

    When you connect to a physical display, NoMachine captures audio from the default speaker (you can check the current default speaker system settings). If you want to forward microphone from your client machine to the remote desktop, you need to click “Mic in” in nxplayer settings (as you did). Then the audio data will be transferred to NoMachine Output (you can see this device as a speaker, but please don’t set it as default, it’s only for collecting voice data) and then recorded by Remapped NoMachine Output (it can also be called NoMachine Microphone) that should be set as the default microphone when you want to record something through the remote desktop.

    To sum up, in order to forward microphone from the client machine and record something on the remote machine, you need to:

    1) Click “Mic in” in the session settings

    2) Ensure that NoMachine virtual device is set as the default microphone (you should have it set automatically during the connection)

    After that you should be able to record whatever you want. Just open a recording app on the remote machine and speak to your local microphone.

    Best regards,

    Kuba

Viewing 15 posts - 1 through 15 (of 59 total)