rkeen

Forum Replies Created

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • in reply to: Mouse often in wrong place #46480
    rkeen
    Participant

    I have the same issue on Mac OS Sonoma 14.2 with NoMachine 8.10.1 on both the client and server. My server is running Alma Linux 8.8 and Gnome 3.32.2, but I’ve had the problem with CentOS 7.9/Gnome 3 in the past as well. The behavior for me is the same as the original poster. I don’t see it all the time, but the following sequence seems to cause it about 25% of the time.

    1. Start with NoMachine not running on the Mac
    2. Launch the NoMachine client
    3. Connect to the host and the mouse will work as expected including when switching to other applications on the Mac and back
    4. Put the computer to sleep without logging out from the host, quitting NoMachine, or closing the connection window
    5. Wake the computer and switch to the still open NoMachine window
    6. The host has automatically logged out so I log back in (all keyboard)
    7. The mouse location will be the first clicked location during that session
    8. Clicking another application on the Mac (e.g. Mail or Numbers) and then clicking back in the NoMachine window will register the correct click location, but it will be stuck there until the next time you click to another application on the Mac
    9. The only way I’ve found to fix the issue temporarily is to quit and reopen NoMachine and then the mouse seems to work without issue until the next time I put the Mac to sleep

    If it makes a difference, I am running with NoMachine in Fullscreen mode on a 4K display. It doesn’t matter if the server resolution matches the client resolution.

    in reply to: Menubar covers remote desktop in fullscreen mode #43808
    rkeen
    Participant

    I solved it … [by hiding the menu bar]

    This is a workaround, not a solution, since you must change the setting for all applications, not just NoMachine. I prefer to have my menu bar visible when not in full screen mode and NoMachine should support the native MacOS full screen mode so it can follow the standard system settings.

    in reply to: Menubar covers remote desktop in fullscreen mode #43383
    rkeen
    Participant

    I have the same issue with the same versions of MacOS and NoMachine but with CentOS 7.9 as the server. At one point I thought I found a setting in NoMachine to hide the toolbar on full screen, but I don’t seem to be able to find it anymore. Ideally you would support full screen natively via the third green button on the window which is currently implemented to zoom (see the NoMachine Zoom image attached) rather than full screen (see the Chrome FullScreen image attached).

Viewing 3 posts - 1 through 3 (of 3 total)