sil04

Forum Replies Created

Viewing 15 posts - 46 through 60 (of 71 total)
  • Author
    Posts
  • in reply to: How to setup server on Centos #463
    sil04
    Participant

    Jason,

    can you please provide output of this command?

    /sbin/iptables -L

    It’s for checking if iptables are still on for some reasons.

    in reply to: nomachine portal server on centos6 #456
    sil04
    Participant

    Is your Portal Server using the default configuration? I.e. Is it configured to connect to the server on the local host (ServerHost localhost is set in portal.cfg file) or to a different server machine?

    If Portal Server connects to the server on its host machine, you should be able to see the previous ‘Default Connection’ session listed among the available sessions when you connect again by web.

    If you don’t see it listed, it can be that some problems occurred. In this case it could be useful to see logs, namely nxserver.log from /usr/NX/var/log.

    Please set debug log level: edit /usr/NX/etc/server.cfg , /usr/NX/etc/node.cfg and /usr/NX/etc/portal.cfg

    uncomment and set the following key: SessionLogLevel 7.

    Then connect from the web, create the connection, close the browser. Connect again by web and get /usr/NX/var/log/nxserver.log

    • This reply was modified 10 years, 8 months ago by sil04.
    in reply to: "No available sessions on this server" error #454
    sil04
    Participant

    Hi volenin,

    which package did you install on Ubuntu (e.g. NoMachine, Workstation) ?

    does ubuntu server have to already have an XServer or Desktop Manager running

    Yes, the XServer must be running to be able to connect to the physical desktop.

    NoMachine (the free version) lets you access the physical desktop remotely and requires that the Xserver is running. You can also use NoMachine on a headless Linux server (without the need of having the X server running), more instructions are available here:

    https://www.nomachine.com/AR10K00710

    Any of the products from the Terminal Server range (e.g. Workstation or Terminal Server, https://www.nomachine.com/enterprise), allows to create virtual desktop sessions. In this case it’s not necessary to have the Xserver running.

    in reply to: terminal server evaluation #452
    sil04
    Participant

    Yes, you can. Run the following command to see when subscription expires:

    $ sudo /usr/NX/bin/nxserver –subscription

    in reply to: nomachine portal server on centos6 #443
    sil04
    Participant

    In the current implementation, web users cannot save their session configuration. However, when the user creates a new virtual desktop, disconnects from that web session (for example by closing the web page) and connects again, he/she should find the previous session listed in the list of available connections. Double click on it to re-open that session.

    The same should happen if the user closes the session by clicking on the Disconnect button from NoMachine menu -> Disconnect panel (ctrl+alt+0 or click on the page peel to open the menu) or by making system logout. If the user instead makes system shutdown the virtual virtual desktop session is terminate and cannot be re-opened later.

    in reply to: nomachine portal server on centos6 #441
    sil04
    Participant

    Hi cperry,

    what do you need exactly to do? To connect by Portal Server to different servers? If yes, this article can be helpful:

    https://www.nomachine.com/AR07K00679

    SectionSession “Default connection”

    allows to define the name of the connection as it will be displayed to users. In the same section you can also define the server host to which the Portal Server will connect. Just edit value set for the ServerHost key if you want to connect to a server different from localhost.

    in reply to: Can't create new virtual desktops #440
    sil04
    Participant

    Hi igor,

    enterprise-node not available for download anymore?

    The enterprise-node package was renamed terminal-server-node to make more clear that such package works as an additional Linux Terminal Server node of an Enterprise Server whose nodes can be also a Windows or Mac hosts.

    The enterprise-node package was renamed terminal-server-node to make more clear
    that such package works as an additional Linux Terminal Server node of an Enterprise Server whose nodes can be also a Windows or Mac hosts.

    Can you please provide the commands you gave on the server to add the node and the corresponding output? More than being sensitive to the hostname given, can be that the node was not added due to some other reasons.

    available desktops still show physical desktops

    This is a bug. If the PhysicalDesktopSharing key is disabled is the server configuration, users must not see the physical desktop listed among the available sessions.

    EnableVirtualGL doesn’t work

    NoMachine 4.0.362 is not able yet to provide hardware support for OpenGL in an automatic way, so it’s not enough to enable it in the EnableVirtualGL key. It’s necessary to execute some manual operations:

    – Run the following script

    /usr/NX/scripts/vgl/vglserver_config -config

    – Reboot the machine.

    – Then launch the OpenGL application by running inside the NoMachine session:

    /usr/NX/scripts/vgl/vglrun <opengl app>

    in reply to: terminal server evaluation #438
    sil04
    Participant

    If you have installed for example Workstation or Terminal Server over a previous NoMachine installation, you have to uninstall, remove the installation directory and re-install the package you want to use.

    You can then check the version once again by running: /usr/NX/bin/nxserver –version

    • This reply was modified 10 years, 8 months ago by sil04.
    in reply to: strict client settings #390
    sil04
    Participant

    tsiganenok,

    an option to disable the !M icon

    you may find how to do here:

    https://www.nomachine.com/forums/forums/topic/remove-menubar#post-360

    and next post on the same topic:

    https://www.nomachine.com/forums/forums/topic/remove-menubar#post-367

    in reply to: How to setup server on Centos #389
    sil04
    Participant

    If I connect client and the server on the same centos machine, it works.

    can be that a firewall rule is blocking port 4000?

    in reply to: can't unlock nx4 session with capital letter in password #388
    sil04
    Participant

    Hi cperry,

    which browser are you using? Does your password contain special characters or spaces?

    It would be also useful to know:

    – Which is your NoMachine server version.
    – Which is the operating system and version of your server host (Ubuntu xyz, Mint xyw)
    – If you are connecting to the physical desktop or if you are creating a new virtual desktop.
    – Version of the desktop (GNOME; KDE, whatever else …).

    in reply to: Lost "resumed" session #381
    sil04
    Participant

    Hi jkrim,

    what do you have installed on the server host? NoMachine 4?

    If you want to check the status of your sessions you can run the following command on the server host:

    $ sudo /usr/NX/bin/nxserver –history

    in reply to: strict client settings #373
    sil04
    Participant

    Hi tsiganenok,

    in NoMachine locking down a configuration happens on the server, not on the client. The client will query the server to know which service is available and allowed, based on the server configuration and profile. This offers better security since it is the server that you mainly want to protect.

    There are two ways to lock down a configuration:

    1. Operating at the server level, by changing the server and node configuration. This will apply to all users connecting to that server.

    2. By creating profile rules. This last option is available only with servers tailored for the enterprise and allow to create configurations also on a per-user basis.

    Regarding of point 1, you can find here instructions about how to enable or disable device sharing services:

    http://www.nomachine.com/AR10K00734

    in reply to: Remove menubar #360
    sil04
    Participant

    I have gone through the settings and the only thing I can see that would disable the server is network services page on server settings and turn off the service, but that does not get rid of the !m in top menu bar.

    Can you please try to do the following?

    – Click on the Monitor (the !M icon) in the system tray to open the menu.

    – Click on ‘Show the server status’ item to open the Server status GUI.

    – Click on ‘Exit the server’.

    This will stop all the NoMachine programs, included the !M icon. NoMachine will be restarted when you reboot the machine.

    in reply to: USB Error on Windows #324
    sil04
    Participant

    You can send to forum[at]nomachine[dot]com.

Viewing 15 posts - 46 through 60 (of 71 total)