jamat13

Forum Replies Created

Viewing 15 posts - 1 through 15 (of 22 total)
  • Author
    Posts
  • in reply to: No display and no mouse #46906
    jamat13
    Participant

    Sorry lubuntu client is 3.11

    all reported behaviour has changed eg no display after screen saver eg mouse click not been seen

    in reply to: No display and no mouse #46892
    jamat13
    Participant

    1) macOS 3.10 client lubuntu 23.04 server – normal

    2) Linus plasma 3.11 client lubuntu 21.04 server – picture

    3) menu -> display -> (no change) Fit in Window – normal

    in reply to: No display and no mouse #46890
    jamat13
    Participant

    Will add dialog later

    Attachments:
    in reply to: EndeavourOS X server not found #46381
    jamat13
    Participant

    <sigh> There are many aspects of Ubuntu I don’t like (we decree you shall …) but I installed Lubuntu 23.10 and everything works out the box. (including mouse, screensaver). This version of Lubuntu runs Xorg.

    in reply to: EndeavourOS X server not found #46380
    jamat13
    Participant

    OK this is bizare but repeated and confirmed:

    openSuSE Tumbleweed rpm downloaded, 8.10 free desktop

    Screensaver off, display, X server not found

    killall lxqt-session

    login screen

    login black screen

    killall lxqt-session

    login screen, set plasma-X11

    login, works normally

    logout

    login screen, set lxqt-session

    login, normal display, no mouse click

    So it looks like

    no X-server == no mouse clicks (I see pointer)

    lxqt-session == no mouse clicks (I see pointer)

    in reply to: EndeavourOS X server not found #46379
    jamat13
    Participant

    Houston we have a problem …

    I have used NoMachine with lxqt on openSuSE many times over the years.

    So overwhelmed by Arch linux I reinstalled Tumbleweed. Downloaded the rpm and *nearly same* problem.L
    [seagull] /home/jam [332]% sudo /etc/NX/nxserver –restart
    [sudo] password for root:
    NX> 162 Disabled service: nxd.
    NX> 162 Disabled service: nxserver.
    NX> 162 Service: nxnode already disabled.
    NX> 111 New connections to NoMachine server are enabled.
    NX> 161 Enabled service: nxserver.
    NX> 162 WARNING: Cannot find X servers running on this machine.
    NX> 162 WARNING: A new virtual display will be created on demand.
    NX> 161 Enabled service: nxd.
    [seagull] /home/jam [333]% ps -ef |grep X
    root      1661  1659  0 21:01 tty2     00:00:00 /usr/bin/Xorg.bin -nolisten tcp -background none -seat seat0 vt2 -auth /run/sddm/xauth_znXojC -noreset -displayfd 16
    nx        3750     1  1 21:06 ?        00:00:00 /usr/NX/bin/nxserver.bin –daemon
    nx        3798  3750  0 21:06 ?        00:00:00 /usr/NX/bin/nxd
    jam       3855  3572  0 21:06 pts/1    00:00:00 grep –color=auto X

    The difference is that I *can* login to NoMachine x-server.

    Please help me find WHY. I will try, but I’m sure plasma desktop will give me the physical display.

    I should be clear from above but there is no Wayland.

    in reply to: EndeavourOS X server not found #46358
    jamat13
    Participant

    I did not mean to imply NoMachine was in anyway defective, I’m exploring and I really appreciate help thanks 🙂

    I installed the NoMachine version. I post picture1 saying “No X server …”

    I then tried create your own server

    Picture2

    Puzzling things:

    If my *session* is plasma (X11) then NoMachine works normally. (Not only for desktop but login screen too)

    I did already do the PKGBUILD edit

    This is the Downloaded version

    [seagull] /home/jam [511]% !487
    sudo /etc/NX/nxserver –restart
    [sudo] password for root:
    NX> 162 Disabled service: nxd.
    NX> 162 Disabled service: nxserver.
    NX> 162 Service: nxnode already disabled.
    NX> 111 New connections to NoMachine server are enabled.
    NX> 161 Enabled service: nxserver.
    NX> 162 WARNING: Cannot find X servers running on this machine.
    NX> 162 WARNING: A new virtual display will be created on demand.
    NX> 161 Enabled service: nxd.

    nxnode runs on plasma session not on lxqt session.

    Only the first connection said “No Server” all subsequent connects go straight to picture2

    I use NoMachine many times daily, If I can’t solve then I’ll change distro.

     

    in reply to: EndeavourOS X server not found #46338
    jamat13
    Participant

    OK I’ve now confirmed on both test and main machines:

    Running plasma X11 operation is normal

    Running lxqt main machine: login wheel turns, test machine: good display but mouse <clicks> totally ignored.

    jamat13
    Participant

    Im using endeverOS which is arch linus.

    I found in the forum saying set PKGBUILD

    _autoservice=y

    This causes nxd to start from systemd and that resolves the problem. It may well be an arch-linux problem so solving it may be a waste of your time 🙁

    in reply to: Garbled File Manager display #45861
    jamat13
    Participant

    I reinstalled High Sierra
    I re-installed NoMachine
    The problem of File Manager not NoMachine into screen is no longer there
    Twas bizarre but no point in wasting time over some strange behaviour

    in reply to: Garbled File Manager display #45857
    jamat13
    Participant

    This is Linux running on imac27. From other machines client display is normal

    Attachments:
    in reply to: Complicated audio set-up with pulse #37690
    jamat13
    Participant

    A day later following a reboot to absolutely make certain that the free product works Workstation works as if there was never an issue- aaargh

    in reply to: Desktop not shared – Workstation #37652
    jamat13
    Participant

    Speculation:

    Since I installed on a new linux-install the only thing I can see: I installed the free version first, removed it and installed the licensed version.

    Uninstall the free version did not rm /usr/etc/var/NX

     

     

    in reply to: Desktop not shared – Workstation #37651
    jamat13
    Participant

    Sorry! I neglected

    dvr@dvrTW:~> sudo rm -fr /usr/NX/
    dvr@dvrTW:~> sudo rm -fr /etc/NX/
    dvr@dvrTW:~> sudo rm -fr /var/NX/

    after which it *does* work. Thanks!

    in reply to: Desktop not shared – Workstation #37650
    jamat13
    Participant

    dvr@dvrTW:~> rpm -qa |grep nomac
    nomachine-workstation-7.8.2-1.x86_64
    dvr@dvrTW:~> sudo rpm -e nomachine-workstation
    [sudo] password for root:
    NX> 702 Uninstalling: nxwebplayer version: 7.8.2.
    NX> 702 Uninstall log is: /usr/NX/var/log/nxuninstall.log.
    NX> 702 Saving configuration file to: /usr/NX/etc/htd.cfg.backup.
    NX> 702 Deleting user: nxhtd from the system.
    NX> 702 Starting uninstall at: Tue Feb 22 09:55:43 2022.
    NX> 702 Uninstalling: nxserver version: 7.8.2.
    NX> 702 Uninstall log is: /usr/NX/var/log/nxuninstall.log.
    NX> 702 Saving configuration file to: /usr/NX/etc/server.cfg.backup.
    NX> 702 Saving usb DB to: /usr/NX/etc/usb.db.backup.
    NX> 702 Uninstalling: nxnode version: 7.8.2.
    NX> 702 Uninstall log is: /usr/NX/var/log/nxuninstall.log.
    NX> 702 Saving configuration file to: /usr/NX/etc/node.cfg.backup.
    NX> 702 Deleting user: nx from the system.
    NX> 702 Uninstalling: nxplayer version: 7.8.2.
    NX> 702 Uninstall log is: /usr/NX/var/log/nxuninstall.log.
    NX> 702 Uninstalling USB module.
    NX> 702 Uninstalling: nxclient version: 7.8.2.
    NX> 702 Uninstall log is: /usr/NX/var/log/nxuninstall.log.
    NX> 702 Uninstall completed at: Tue Feb 22 09:55:57 2022.
    dvr@dvrTW:~> rm -fr .nx
    dvr@dvrTW:~> sudo rpm -ivh nomachine-workstation_7.8.2_1_x86_64.rpm
    Verifying...                          ################################# [100%]
    Preparing...                          ################################# [100%]
    Updating / installing...
    1:nomachine-workstation-7.8.2-1    ################################# [100%]
    NX> 701 Starting update at: Tue Feb 22 09:56:41 2022.                                                                    10,0-1        All
    NX> 701 Updating: nxclient version: 7.8.2.
    NX> 701 Using installation profile: SUSE.
    NX> 701 Update log is: /usr/NX/var/log/nxupdate.log.
    NX> 701 Updating: nxplayer version: 7.8.2.
    NX> 701 Using installation profile: SUSE.
    NX> 701 Update log is: /usr/NX/var/log/nxupdate.log.
    NX> 700 Installing: nxnode version: 7.8.2.
    NX> 700 Using installation profile: SUSE.
    NX> 700 Install log is: /usr/NX/var/log/nxinstall.log.
    /usr/NX/scripts/setup/nxnode: line 10633: /etc/pam.d/su: No such file or directory
    NX> 700 Creating configuration in: /usr/NX/etc/node.cfg.
    NX> 701 Updating: nxserver version: 7.8.2.
    NX> 701 Using installation profile: SUSE.
    NX> 701 Update log is: /usr/NX/var/log/nxupdate.log.
    NX> 701 Saving configuration file to: /usr/NX/etc/server.cfg.backup.
    NX> 701 Creating configuration in: /usr/NX/etc/server.cfg.
    NX> 701 Updating: nxwebplayer version: 7.8.2.
    NX> 701 Using installation profile: SUSE.
    NX> 701 Update log is: /usr/NX/var/log/nxupdate.log.
    NX> 701 Update completed at: Tue Feb 22 09:56:52 2022.
    NX> 701 NoMachine was configured to run the following services:
    NX> 701 NX service on port: 4000
    NX> 701 HTTP service on port: 4080
    NX> 701 HTTPS service on port: 4443

     

    I can’t make an image small enough to show “No available Desktops”

    http://tigger.ws/downloads/nom.jpg

Viewing 15 posts - 1 through 15 (of 22 total)