zaq

Forum Replies Created

Viewing 15 posts - 46 through 60 (of 90 total)
  • Author
    Posts
  • zaq
    Participant

    Hello Richcmwang,

    Looks like the error message can be triggered by adding or changing
    any *.desktop file. It isn’t caused by error in *.desktop file. You
    can easily trigger this message by changing date:

    sudo touch /usr/share/applications/firefox.desktop

    In syslog I’ve found other type of error messsages:

    gnome-software[3456]: Failed to find one package for NoMachine-base.desktop, /usr/share/applications/NoMachine-base.desktop, [0]

    You can disable them by adding to:

    /var/lib/dpkg/info/nomachine.list

    these lines:

    /usr/share/applications/NoMachine-base.desktop
    /usr/share/applications/NoMachine-base-unity.desktop
    /usr/share/applications/NoMachine-base-xfce.desktop
    /usr/share/applications/NoMachine-nxs.desktop
    /usr/share/applications/NoMachine-nxv.desktop
    /usr/share/applications/NoMachine-status.desktop
    /usr/share/applications/NoMachine-status-unity.desktop
    /usr/share/applications/NoMachine-status-xfce.desktop

    in reply to: Enterprise Client requires admin privileges #20400
    zaq
    Participant

    Hello,

    Please download again. There was a slight hitch with the package online
    and it’s now been fixed. Sorry for any inconvenience.

    in reply to: What is the NX User account? #19878
    zaq
    Participant

    Looks like everything is ok. User nx is created and used by NoMachine. Also this user shouldn’t be visible in login window. Do you have other doubts?

    in reply to: What is the NX User account? #19812
    zaq
    Participant

    Hello Fastidious,

    Nx user is needed for proper working. You can find more in:

    https://www.nomachine.com/AR01N00871

    However if you see user nx as available user in Login Window then please let us know and check using following command:

    sudo /usr/bin/defaults read /Library/Preferences/com.apple.loginwindow HiddenUsersList

    In this case helpful will be nxinstall.log, nxupdate.log from:

    /Library/Application\ Support/NoMachine/var/log/

    Log files please send to forum[at]nomachine[dot]com.

    • This reply was modified 5 years, 7 months ago by zaq.
    in reply to: Installation fails: missing ssh keyfile #19530
    zaq
    Participant

    Hello Marty39

    Looks like you have Mint 64 bits and you installed a package for 32 bits:

    1. Download the x64 package:

    https://www.nomachine.com/download/download&id=5

    2. Uninstall current package:

    sudo dpkg -P nomachine

    3. Remove all leftovers:

    sudo rm -rf /usr/NX /etc/NX /var/NX

    4. Install new package:

    sudo dpkg -i nomachine_6.2.4_1_amd64.deb

    To check architecture of your machine you can use this command:

    uname -m

    in reply to: Centos 6 nx installation error (cannot add user: nx) #15639
    zaq
    Participant

    Hello,

    Do you use ActiveDirectory/LDAP/domain users?

    Could you send to us output from:

    1) id nx

    2) getent passwd nx

    3) /usr/sbin/useradd -d '/var/NX/nx' -p '*' -g nx -s /bin/false -r nx

    in reply to: Doesn't work after installing new version 5.3.10_7 #15572
    zaq
    Participant

    Hello dmanushin,

    Looks like you have 64 bits (x86_64) operating system and you installed NoMachine package
    for 32 bits (i686). I expect that you use NoMachine Free, so I use this type of installation in
    my instruction.

    Firstly please uninstall current NoMachine package:

    sudo rpm -e nomachine

    remove leftowers:

    sudo rm -rf /usr/NX /etc/NX /var/NX

    Download the right package:

    https://www.nomachine.com/download/download&id=14

    install the new package:

    sudo rpm -i nomachine_5.3.10_6_x86_64.rpm

    Now you can use NoMachine.

    in reply to: Error is 134: Protocol error (Ubuntu) #14944
    zaq
    Participant

    Hi mikeev,

    Looks like your graphic card without a connected monitor works
    in power save mode and doesn’t draw graphics properly. This is
    the reason why you got black screen. The solution is to disable
    graphical runlevel of your headless Ubuntu 16.04. You can simple
    run:

    sudo systemctl stop gdm.service

    sudo /etc/NX/nxserver --restart

    You should got expected warning about X server.

    sudo systemctl set-default -f multi-user.target

    Now you can connect to the machine and NoMachine create graphical
    session. If you got problems with resolution you can change it in
    display settings:

    https://www.nomachine.com/changing-how-you-view-the-remote-host

    If you want to restore your previous default runlevel just execute:

    sudo systemctl set-default -f graphical.target

    and after next reboot your OS should display Gnome.

    in reply to: Error is 134: Protocol error (Ubuntu) #14844
    zaq
    Participant

    Hello mikeev

    We couldn’t reproduce your problem in our laboratory. We need more
    information. Please follow steps below:

    1. Check if you have installed desktop environment. Please send
    the output to us.

    dpkg -l ubuntu-desktop

    ls -l /etc/X11/Xsession

    2. Check if Xorg process exists. Please send the output to us.

    ps -ef | grep -i xor | grep -v grep

    3. Gather logs:

    a) Edit the /usr/NX/etc/server.cfg file. Uncomment and set the
    following:

    SessionLogLevel 7

    b) Edit the /usr/NX/etc/node.cfg file. Uncomment and set the
    following:

    SessionLogLevel 7

    and:

    SessionLogClean 0

    c) Reboot nxserver:

    sudo /usr/NX/bin/nxserver --restart

    d) Reproduce the problem – try create connection to Ubuntu headless
    when monitor isn’t connected.

    4. Pack the whole log directory:

    tar czf log.tar.gz /usr/NX/var/log

    5. Send the log archive to forum[at]nomachine[dot]com

    zaq
    Participant

    Hello higrys

    We couldn’t reproduce the problem in our laboratory. Could you
    reinstall NoMachine again and reproduce problem?

    1. Uninstall NoMachine:

    sudo dpkg -P nomachine

    2. Remove all directories:

    sudo rm -rf /usr/NX /etc/NX /var/NX

    3. Check architecture of your OS:

    uname -a

    If the output include: x86_64 x86_64 x86_64 GNU/Linux
    you should use x64 package:

    nomachine_5.2.21_1_amd64.deb

    if you got: i686 GNU/Linux or i386 GNU/Linux
    please use x32 package:

    nomachine_5.2.21_1_i386.deb

    4. Install NoMachine.

    x64 system:

    sudo dpkg -i nomachine_5.2.21_1_amd64.deb

    x32 system:

    sudo dpkg -i nomachine_5.2.21_1_i386.deb

    5. Gather logs and reproduce the problem like in this link:

    https://www.nomachine.com/DT07M00098#1

    and send packed logs to forum[at]nomachine[dot]com.

    in reply to: Cannot find default environment after TR09N07188 fix #14457
    zaq
    Participant

    Hello EddieA

    Could you set in your Slackware /usr/NX/etc/node.cfg:

    DefaultDesktopCommand "/usr/bin/startSession.sh"

    Put attached script to /usr/bin/ and set this permissions:

    chown root:root /usr/bin/startSession.sh

    chmod 555 /usr/bin/startSession.sh

    and try to run NoMachine connection to your Slackware.

    • This reply was modified 7 years, 1 month ago by zaq.
    • This reply was modified 7 years, 1 month ago by zaq.
    in reply to: Cannot install NoMachine on Linux (Ubuntu Gnome) #14232
    zaq
    Participant

    Hello,

    You can simply remove broken NoMachine installation:

    sudo dpkg -P nomachine

    sudo rm -rf /usr/NX /etc/NX /var/NX

    and install again

    • This reply was modified 7 years, 1 month ago by zaq.
    in reply to: NoMachine client missing from Applications #13930
    zaq
    Participant

    Yes it’s a bug, it’ll be fixed in a next release.

    in reply to: NoMachine client missing from Applications #13921
    zaq
    Participant

    Hello iainhallam

    When you installed package nomachine_5.2.11_1_x86_64.rpm you
    shouldn’t install nomachine-enterprise-client because nomachine
    ‘server’ package also includes ‘client’ part. If you need on
    your machine only NoMachine client, please just run as root:

    /usr/NX/scripts/setup/nxplayer --update

    This fixes the problem with ‘Applications’ menu entry.

    If you need installed server and client parts on your machine,
    please remove existing package:

    rpm -e nomachine-enterprise-client

    and install again:

    rpm -i nomachine_5.2.11_1_x86_64.rpm

    in reply to: Server not fully starting, can’t connect #13761
    zaq
    Participant

    Looks like you are trying to connect by SSH protocol to the port 4000.
    To fix this you can create a new connection in nxplayer and use
    default settings or you can change your current connection:

    1. Open nxplayer and find icon of your current connection.

    2. Click right mouse button on the connection.

    3. From a context menu choose ‘Edit connection’.

    4. In ‘Protocol’ field choose NX.

    5. In ‘Port’ field set 4000.

    6. Accept your changes by clicking ‘OK’ button.

    After the fix if you still have problem, please try connect again.
    Wait until error shows up in nxplayer and then click ‘Save logs’
    button. Please save and send the log file to us.

Viewing 15 posts - 46 through 60 (of 90 total)